Перейти к содержанию
Азат1982

Проблема с шаговым двигателем и отсутствие луча

Рекомендуемые сообщения

Здравствуйте. 

У меня китайский станок. Раньше стояла трубка на 80 Вт и блок розжига соответствующий. Как трубка на 80 Вт померла решил поставить трубку на 50 Вт и блок розжига на 50Вт.

Так как штекер и буквенные обозначения совпали просто перекинул штекер( фото ). Но лазерный луч не шел ни при запуске, ни при нажатии на кнопку тест в блоке розжига. Черный провод перенес на место с обозначением 5V. После этого луч при нажатии на тест в блоке розжига пошел и амперметр показал 15-16 мА. Но при запуске реза и при нажатии  кнопки тест на самом станке ничего не происходит.... Я исключил датчик воды перемкнув провода.

Из всего этого могу сделать вывод, что трубка и блок розжига живы и вопрос скорее в неправильном подключении проводов. Кто то может знает, что куда подсоединять. Могу, если необходимо скинуть фото проводов что куда подсоединяется.

Теперь шаговые двигатели.

ШД по оси Y перестал откликаться на нажатия на корпусе станка. Потом перестал откликаться и ШД по оси Х

Причем если я пускаю рез с компьютера, то ШД по оси Х движется, а Y нет.

Далее я перекинул провода между драйверами и заработало(при пуске с компьютера) ровно наоборот. Из этого могу сделать вывод, что двигатель и проводка на оси Y в порядке и вопрос к драйверу. Но индикатор на "неработающем драйвере" горит зеленым. И визуальный осмотр внутренностей ничего не дал.  И мне теперь непонятно в чем проблема. И ремонтируется ли драйвер сам? 

И почему ШД не реагируют на нажатие кнопок движения на корпусе станка. При этом работая с меню видно, что эти кнопки работают(листают)

 

 

 

 

IMG_20210505_165714.jpg

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Доброго дня.

Для начала выясните, от куда куда какие провода подходят к блоку розжига.

Дальше уже будет видно что произошло.

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Награды пользователя

Все три провода идут к контроллеру (Красный, черный и зелено-желтый) 

Два других это датчик воды, который я закоротил.

IMG_20210505_182933.thumb.jpg.98afcdf863c77d71274aebdee89002b2.jpg 

 

IMG_20210505_182853.jpg

Изменено пользователем Азат1982

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

А что за контроллер?

 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Награды пользователя

CNC-LS240A

IMG_20210505_191435.jpg

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

 

3 часа назад, Азат1982 сказал:

ни при нажатии на кнопку тест в блоке розжига

Он будет только при отключённом управляющем разъёме.

3 часа назад, Азат1982 сказал:

Черный провод перенес на место с обозначением 5V.

 Не правильно. Он должен быть на IN у блока розжига т.к. у контроллера DA1 это выход аналогового управляющего сигнала. 

 

3 часа назад, Азат1982 сказал:

Причем если я пускаю рез с компьютера, то ШД по оси Х движется, а Y нет.

Далее я перекинул провода между драйверами и заработало(при пуске с компьютера) ровно наоборот.

Драйвера не пострадали.

Вероятно, подключив на выход от контроллера 5 Вольт от блока розжига  Вы могли ненароком что-нибудь спалить в контроллере.

При выключении и включении станка каретка обычно отъезжает в крайнее положение для поиска концевиков - у Вас так было до начала проблем?
Теперь при включении станка какая-нибудь ось куда-либо движется?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Награды пользователя

21 минуту назад, PavelK сказал:

Он будет только при отключённом управляющем разъёме.

Не соглашусь. Это редкий случай. Как правило, тест на самом БВН прекарсно работает и с подключённым сигнальным разъёмом, но ток при этом максимальный, а с отключённым разъёмом примерно 45-50%. Есть блоки розжига, которые в любом случае требуют сигнала о наличие потока воды.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

43 минуты назад, PavelK сказал:

 

Он будет только при отключённом управляющем разъёме.

 Не правильно. Он должен быть на IN у блока розжига т.к. у контроллера DA1 это выход аналогового управляющего сигнала. 

 

Драйвера не пострадали.

Вероятно, подключив на выход от контроллера 5 Вольт от блока розжига  Вы могли ненароком что-нибудь спалить в контроллере.

При выключении и включении станка каретка обычно отъезжает в крайнее положение для поиска концевиков - у Вас так было до начала проблем?
Теперь при включении станка какая-нибудь ось куда-либо движется?

Что то не припомню, что бы он так делал когда-либо. Сейчас при включении станка ничего не движется. И я могу подвигать ось Х только с программы лазеркат задав длину хода. Нажав на него он движется по оси Х на заданное расстояние. А Y молчит и в этом случае.

Вообще когда еще по Х-у нажимая на  корпусе станка он двигался я в меню тыкал и он перестал работать. При этом меню там простое и ничего такого я не нажимал. Думаю совпадение.

Завтра тогда контроллер смотреть буду. Но там тоже зеленая лампочка POW - горит, ALARM -не горит и RUN - моргает зеленым. 

Думаю, а не может все это от программы как то нарушиться? Станок все таки "повидавший" 2013 года. Руида.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Азат1982 , а станок вообще работал у вас нормально или купили БУ?  Установили софт и залили в него не его конфиг, от другой версии контроллера? 

А по большому счёту, я бы контроллер заменил на более свежий .. старый он очень .. 

Изменено пользователем Dan

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

10 минут назад, Dan сказал:

Азат1982 , а станок вообще работал у вас нормально или купили БУ?  Установили софт и залили в него не его конфиг, от другой версии контроллера? 

А по большому счёту, я бы контроллер заменил на более свежий .. старый он очень .. 

Да, работал. Примерно 1.5 года. Потом луч пропал. Я решил поменять трубку. Но так как я режу оргстекло 3 мм, прикинул, что 80 Вт трубка ни к чему. И взял 50 Вт и трубу и блок. Ничего из софта не устанавливал, ничего не заливал. 

Поменять то контроллер можно, только не уверен, что поможет. А то так половину станка поменять можно пока причину найду)

 

Изменено пользователем Азат1982

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

1 минуту назад, Азат1982 сказал:

Да, работал. Примерно 1.5 года. Потом луч пропал. Я решил поменять трубку. Но так как я режу оргстекло 3 мм, прикинул, что 80 Вт трубка ни к чему. И взял 50 Вт и трубу и блок. Ничего из софта не устанавливал, ничего не заливал. 

Ну, вы ж понимаете, что само сломаться не могло то, что нормально работало .. ))) Я заменил много десятков трубок, драйверов, контроллеров и т.д., но ничего попутно не переставало работать из того что работало. 

Значит, при замене, что-то было сделано не так, и теперь приходится изучать последствия, что бы устранить причину. 

Отсюда и вопрос: Что ещё вы делали в станке? 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

12 минут назад, Dan сказал:

Ну, вы ж понимаете, что само сломаться не могло то, что нормально работало .. ))) Я заменил много десятков трубок, драйверов, контроллеров и т.д., но ничего попутно не переставало работать из того что работало. 

Значит, при замене, что-то было сделано не так, и теперь приходится изучать последствия, что бы устранить причину. 

Отсюда и вопрос: Что ещё вы делали в станке? 

Если говорить про луч, то ничего не делал особого. У меня даже были сомнения, когда луч пропал.. А труба ли виновата была. Может что то другое вышло тогда из строя, потому как фиолетовый луч шёл. Луч пропал в течение дня постепенно уменьшая мощность. Писк кстати перед отказом был! 

Но мне сказали, что трубка это и меняй давай. 

А про движки я думаю, что то наделал похоже сам. Может на самом деле контроллер спалил частично, как выше писали. Но опять таки замена местами проводов на драйверах показала, что и шд и провода от неё  и соответственно контроллер в норме. 

Думаю отнести контроллер и драйвер на "прозвон" электронщику. Может что сгоревшее найдёт. 

Изменено пользователем Азат1982

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

6 минут назад, Азат1982 сказал:

Но мне сказали, что трубка это и меняй давай. 

Блок розжига можно проверить на искру ... БВН 80 Вт. должен разжечь дугу на расстоянии 40-50 мм. Так вы точно выясните, умер БВН или труба. Но умирающая труба легко могла потащить за собой и БВН.  

В остальном пока непонятно. Лично я начал бы проверку с питания, и проверку всех соединений на корректность и качество подключения. 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

4 минуты назад, Dan сказал:

Блок розжига можно проверить на искру ... БВН 80 Вт. должен разжечь дугу на расстоянии 40-50 мм. Так вы точно выясните, умер БВН или труба. Но умирающая труба легко могла потащить за собой и БВН.  

В остальном пока непонятно. Лично я начал бы проверку с питания, и проверку всех соединений на корректность и качество подключения. 

Незачем проверять. Я поменял блок розжига и поставил 50Вт. Даёт 15-17 мА. Трубка не новая, но луч даёт при нажатии на тест. Поэтому с питанием думаю все нормально. А вот корректно ли всё подключил...  Это вопрос. Контакты где сомнения были зачистил.  

Странно, что он с корпуса станка перестал двигать каретку. Вообще движение каретки с помощью стрелок на станке завязано на контроллере или нет?

Может видео снять всего процесса?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

2 минуты назад, Азат1982 сказал:

Поэтому с питанием думаю все нормально.

Я говорю про питание с БП на контроллер и драйверы .. Там проверить не помешает. 

3 минуты назад, Азат1982 сказал:

Вообще движение каретки с помощью стрелок на станке завязано на контроллере или нет?

Завязано.

3 минуты назад, Азат1982 сказал:

Может видео снять всего процесса?

Было бы неплохо посмотреть. 

Изменено пользователем Dan

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Насколько я понял, концевики индуктивные и питаются 24В с контролера. Интересно они срабатывают?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты
Награды пользователя

6 минут назад, Dan сказал:

Я говорю про питание с БП на контроллер и драйверы .. Там проверить не помешает. 

Завязано.

Было бы неплохо посмотреть. 

Завтра сниму.

С блока питания не проверял кстати..

3 минуты назад, vasa29 сказал:

Насколько я понял, концевики индуктивные и питаются 24В с контролера. Интересно они срабатывают?

Думаю по Х срабатывает. Потому как запуская рез он имитирует его, правда двигаясь только по оси Х. А потом возвращается.

И если скажем сдвинуть каретку с нуля и нажать на Reset, то он возвращается в ноль. Правда тоже только по Х.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

7 часов назад, Азат1982 сказал:

Потому как запуская рез он имитирует его, правда двигаясь только по оси Х. А потом возвращается.

И если скажем сдвинуть каретку с нуля и нажать на Reset, то он возвращается в ноль. Правда тоже только по Х.

Т.е., только Y отвалился? Проверяйте подключение контроллер ->драйвер и драйвер->ШД. Как ни странно, но и там бывают обрывы проводов. Буквально, неделю назад у одного клиента и был такой случай - обрыв провода от драйвера к ШД. Как и почему, не известно, ибо там всё статично, но, тем ни менее, обрыв был. ) Предполагаю, что лазили туда и зацепили, но, как и всегда: "Ничего не трогал, никуда не лазил. Утром включил, не работает".  И микрошаги в контроллере сбились сами. ) Короче, со всех сторон одна мистика .. ))) 

Изменено пользователем Dan

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

50 минут назад, Dan сказал:

Т.е., только Y отвалился? Проверяйте подключение контроллер ->драйвер и драйвер->ШД. Как ни странно, но и там бывают обрывы проводов. Буквально, неделю назад у одного клиента и был такой случай - обрыв провода от драйвера к ШД. Как и почему, не известно, ибо там всё статично, но, тем ни менее, обрыв был. ) Предполагаю, что лазили туда и зацепили, но, как и всегда: "Ничего не трогал, никуда не лазил. Утром включил, не работает".  И микрошаги в контроллере сбились сами. ) Короче, со всех сторон одна мистика .. ))) 

Обрыв подсоединения думаю можно исключить так как я ко всей проводке Y подключал драйвер от Х и всё двигалось по оси Y. 

А когда подключил к проводке Х , драйвер от Y то движение по Х- оси не наблюдается.

Поэтому на драйвер начал я сваливать вину. Но там тоже лампочки зелёные горят, которые вроде как говорят об исправности.

Может я что то не так понимаю?)

Видео позже сниму как там и что. 

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

53 минуты назад, Азат1982 сказал:

Обрыв подсоединения думаю можно исключить так как я ко всей проводке Y подключал драйвер от Х и всё двигалось по оси Y. 

А когда подключил к проводке Х , драйвер от Y то движение по Х- оси не наблюдается.

Полагаю, переключали только выходы на ШД?

А если и сигнальные колодки перекинуть? Что бы понять, есть сигнал с самого контроллера или нет?

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

3 минуты назад, Dan сказал:

Полагаю, переключали только выходы на ШД?

А если и сигнальные колодки перекинуть? Что бы понять, есть сигнал с самого контроллера или нет?

Всё перекидывал, что на фото. То есть провода между шд и драйвером. А так же между контроллером и драйвером. Получается на фото слева это к шд. А справа к контроллеру.

IMG_20210429_124822.jpg

Вот когда к этим проводам, что на фото подключаю драйвер Х, то движется нормально.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

8 минут назад, Азат1982 сказал:

Всё перекидывал, что на фото.

Если всё перекидывал на ось Х и ШД и управление, и драйвер не реагировал, меняй драйвер.

Но, судя по такой срани в станке, я не удивлён, что там что-то умерло.

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

39 минут назад, Dan сказал:

Если всё перекидывал на ось Х и ШД и управление, и драйвер не реагировал, меняй драйвер.

Но, судя по такой срани в станке, я не удивлён, что там что-то умерло.

А драйвер сам не ремонтопригоден?

И почему интересно с кнопок на станке не двигается хотя бы ось Х....

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

31 минуту назад, Азат1982 сказал:

А драйвер сам не ремонтопригоден?

Да, ремонтопригоден.

31 минуту назад, Азат1982 сказал:

И почему интересно с кнопок на станке не двигается хотя бы ось Х....

Может панель перестала работать. У себя на Литре я уже поменял одну панель - затыканные кнопки перестали работать. Может залезли в настрйоки и что-то погнули ...

Изменено пользователем Dan

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Это видео про драйвера, и движение каретки. Но тут мне все понятно, надо менять драйвер. Только почему со станка не движется все это непонятно.

Второе видео про луч.

26 минут назад, Dan сказал:

Да, ремонтопригоден.

Может панель перестала работать. У себя на Литре я уже поменял одну панель - затыканные кнопки перестали работать. Может залезли в настрйоки и что-то погнули ...

Кнопки сами работают, по крайней мере в меню листать с помощью этих кнопок можно. И они при нажатии пикают как всегда.

Изменено пользователем Азат1982

Поделиться сообщением


Ссылка на сообщение
Поделиться на другие сайты

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Гость
Ответить в этой теме...

×   Вставлено с форматированием.   Вставить как обычный текст

  Разрешено использовать не более 75 эмодзи.

×   Ваша ссылка была автоматически встроена.   Отображать как обычную ссылку

×   Ваш предыдущий контент был восстановлен.   Очистить редактор

×   Вы не можете вставлять изображения напрямую. Загружайте или вставляйте изображения по ссылке.


  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

  • Похожий контент

×
×
  • Создать...